Архив рубрики: Сеть/Интернет

Доступ к cisco с определенного адреса

Подключаемся к консоле CISCO:

  1. входим в раздел администрирования: conf t

2. Войдите в режим конфигурации списка доступа под именем ADMIN-MGT и добавьте запись deny any в конец ACL-списка.

cisco(config)# ip access-list standard ADMIN-MGT 
cisco(config-std-nacl)#

3. добавьте доступ к устройству для определенного IP либо подсети

cisco(config-std-nacl)# permit host 192.168.77.77
( Доступ с IP 192.168.77.77 )

cisco(config-std-nacl)# permit 192.168.77.10 0.0.0.10
( Доступ с диапазона IP 192.168.77.10- 192.168.77.20 )

Создание запрещающей записи не требуется, поскольку в конце любого ACL-списка имеется косвенная запись deny any.

Теперь, когда вы создали именованный список ACL, примените его на каналах vty.

cisco(config)# line vty 0 4 
cisco(config-line)# access-class ADMIN-MGT in 
cisco(config-line)# exit

проверяем доступ к устройству с IP вне указаного диапазона, если все верно — сохраняем конфигурацию
copy running-config startup-config

R1(config-std-nacl)# exit

Проброс Електронного ключа (токен) АВТОР Электронный ключ SecureToken-337F на PVE PROXMOX VPS

Создаем виртуальную машину с стандартными параметрами Windows 10.
В разделе Hardware добавляем USB устройство и порт.

Изменяем Microsoft Group Policy для отключения проброса устройства, для корректной работы с токеном средством RDP.

Открываем Local Group Policy

Переходим в раздел Конфигурация компьютера, Административные шаблоны, Компоненты Windows

Службы удаленного рабочего стола -> Узел сеанса удаленного рабочего стола -> Перенаправление устройств и ресурсов.

Включить «Не разрешать перенаправление дисков» (возможно и смарт карт ниже в меню)

Установить расширение ИИТ Пользователь ЦСК-1. Библ. подп. (web-р.)

и EUSignWebInstall.exe http://iit.com.ua/download/productfiles/EUSignWebInstall.exe

Авторизоваться на необходимом сайте.

The used table type doesn’t support FULLTEXT indexes

FULLTEXT доступен только в MyISAM, меняем тип таблицы
MyISAM и после чего выполняем запрос к БД

ALTER TABLE ost__search ENGINE = MyISAM;
ALTER TABLE ost__search
ADD PRIMARY KEY (object_type,object_id);
ALTER TABLE ost__search ADD FULLTEXT KEY search (title,content);

Резервный L2TP-Server Mikroik

Имеется сеть: Основной Mikrotik (l2tp сервер+доступ в интернет) и Mikrotik в роли L3 коммутатора, необходимо сделать резерв l2tp сервера.

  1. Настраиваем резервый Mikrotik под L2TP аналогично основному используя уникальные IP для PPP-Secrets, MTU на несколько значений выше и те же route

2. Со стороны клиента добавляет второе подключение L2TP (Interfaces — Add — L2TP Client)

IP — Route добавляем второй L2TP сервер.
со шлюзом на резервный L2TP сервер и большой
distance c комментом reserv

Для основного канала ставим коммент main

Переходим в Tools — Netwatch и добавляем правило блокировки второго канала в случае доступности основного:
IP — IP для l2tp канала данного офиса с основного Mikrotik

Если канал доступен:

/ip route set [find comment=»vpn-main»] disabled=no

/ip route set [find comment=»vpn-resern»] disabled=yes

Если канал недоступен то:

/ip route set [find comment=»vpn-main»] disabled=yes
/ip route set [find comment=»vpn-reserv»] disabled=no


3. На L3 Mikrotik дублируем route для l2tp подключений с указанием резервного шлюза с distance на 1 больше основного:

4. Добавляем автоматическое переключение шлюзов. Переходим в Tools — Netwatch и добавляем правило:

Где 10.20.20.30 IP адрес который пингуем для определения доступен ни канал (в моем случае это IP который получает клиент в качестве Pref.Source IP от основного Mukrotik)
Интервал 5 секунд, обычно достаточно 1 минуты.

UP: в случае доступности IP отключаем резерв и активируем основной канал:
/ip route set [find comment=»main-l2tp-user1″] disabled=no
/ip route set [find comment=»reserve-l2tp-user1″] disabled=yes

DOWN: в случае отсутствия пинга к IP отключаем основной канал и активируем резервный канал:
/ip route set [find comment=»main-l2tp-user1″] disabled=yes
/ip route set [find comment=»reserve-l2tp-user1″] disabled=no

IPMI сброс пароля и прочее x8-X11 supermicro

  1. Загрузится в ОС на самом сервере или с LiveCD
  2. Скачать IPMICFG (DOS, Windows, Linux, UEFI Shell) https://www.supermicro.com/SwDownload/SwSelect_Free.aspx?cat=IPMI
  3. Заходим в директорию с программой cd /opt/IPMICFG_*/Linux/64bit
  4. разрешаем исполнения
    chmod +x IPMICFG-Linux.x86_64
  5. создаём символическую ссылку для удобства использования ln -s $(pwd)/IPMICFG-Linux.x86_64 /usr/local/sbin/ipmicfg
  6. Если винда то файл ipmicfg-win.exe
  7. сброс к заводским установкам: ipmicfg -fd

либо с опцией 1,2,3

ipmicfg -fd 3

Ждем сообщения Reset to the factory default completed!

8. Информация о сети

root@(none):~# ipmicfg -m

IP=192.168.101.101

MAC=00:XX:XX:XX:XX:XX

root@(none):~# ipmicfg -k

Net Mask=255.255.255.0

root@(none):~# ipmicfg -gIP=192.168.101.1

9. ВКЛ/ВЫКЛ сети dhcp

ipmicfg -dhcp on

ipmicfg -dhcp off

После сброса к заводским установкам вы можете использовать такие значения:

  • Пользователь: ADMIN
  • Пароль: ADMIN

Получить список пользователей:
ipmicfg -user list

Возврат с openwrt на стандартную прошивку TL-WDR4300 (tp-link N750)

Облазив интернеты с больше нерабочими ссылками на stripped версии (а именно TL-WDR4300-V1-stripped.zip) пришлось делать свою.
С официального сайта https://www.tp-link.com/ru-ua/download/TL-WDR4300.html#Firmware скачиваем прошивку, я выбрал TL-WDR4300_V1_141208_RU, распаковываем архив и достаем файл wdr4300v1_ru_3_14_1_up_boot(141208).bin, вот с него и будем делать нашу stripped версию, так как прошивка имеет приставку BOOT необходимо обрезать загрузочный сектор, первые 0x20200 (that is 131,584 = 257*512) байт от оригинального файла: (1*512 Vendor-info + 256*512 U-Boot).
Достаточно просто если под рукой есть линукс, так как консоль жалуется на спецсимволы то удалим скобки, т.е. переименуем файл в wdr4300v1_ru_3_14_1_up_boot.bin
После этого обрезаем загрузочный секртор командой:
dd if=wdr4300v1_ru_3_14_1_up_boot.bin of=wdr4300v1_ru_3_14_1_up.bin skip=257 bs=512
создав wdr4300v1_ru_3_14_1_up.bin который нам и необходим.
Заходим в админку текущего OpenWRT -> система -> обновление и загружаем wdr4300v1_ru_3_14_1_up.bin
Ждем пару минут и заходим в родную прошивку TP-Link по адресу http://192.168.0.1

Linux Mint 18 Cinnamon — Vino VNC

Данный VNC сервер есть по умолчанию, для активации вводим пароль, чтоб добавить доступ для подключения Windows устройств устанавливаем dconf-editor

1) $ sudo apt-get install dconf-editor
2) $ dconf-editor
org > gnome > desktop > applications > remote-access
3) снимаем флаг напротив «REQUIRE-ENCRYPTION»
Можно подключатся.