Ubuntu драйвера для UHD Graphics 730 | i5-11400

Перевірити інформацію для графічного ядра:

lspci -v |grep -A8 VGA

Крок 1: Додати репозиторій:

sudo apt-get install -y gpg-agent wget

wget -qO - https://repositories.intel.com/graphics/intel-graphics.key |
  sudo gpg --dearmor --output /usr/share/keyrings/intel-graphics.gpg
echo 'deb [arch=amd64,i386 signed-by=/usr/share/keyrings/intel-graphics.gpg] https://repositories.intel.com/graphics/ubuntu jammy arc' | \
  sudo tee  /etc/apt/sources.list.d/intel.gpu.jammy.list

Крок 2: Встановити OEM ядро

sudo apt-get update && sudo apt-get install -y  linux-image-5.17.0-1019-oem

Перезавантажити:

sudo reboot

перевірити версію активного ядра (потрібно 5.17.0-1019-oem)

uname -r
sudo apt-get update

sudo apt-get -y install \
    gawk \
    dkms \
    linux-headers-$(uname -r) \
    libc6-dev udev

Крок 3: встановлення DKMS модулів ядра

sudo apt-get install -y intel-platform-vsec-dkms intel-platform-cse-dkms

sudo apt-get install -y intel-i915-dkms intel-fw-gpu 

Крок 4: Встановлення пакетів run-time

sudo apt-get install -y \
  intel-opencl-icd intel-level-zero-gpu level-zero \
  intel-media-va-driver-non-free libmfx1 libmfxgen1 libvpl2 \
  libegl-mesa0 libegl1-mesa libegl1-mesa-dev libgbm1 libgl1-mesa-dev libgl1-mesa-dri \
  libglapi-mesa libgles2-mesa-dev libglx-mesa0 libigdgmm12 libxatracker2 mesa-va-drivers \
  mesa-vdpau-drivers mesa-vulkan-drivers va-driver-all

Перезавантаження:

sudo reboot

На цьому інсталяція завершена, докладніше та додаткові функції на сайті https://dgpu-docs.intel.com/installation-guides/ubuntu/ubuntu-jammy-arc.html

Драйвери для JCX-001 usb to lan realtek-r8152-linux

Архів з драйвером.
Оригінал — https://github.com/wget/realtek-r8152-linux (без dkms.conf)
Після скачування та розпакування архіву заходимо в термінал в директорію з файлами:

sudo apt install build-essential dkms
sudo mkdir /usr/src/r8152-2.13
sudo cp -R * /usr/src/r8152-2.13
sudo cp /usr/src/r8152-2.13/50-usb-realtek-net.rules /lib/udev/rules.d/
sudo dkms add -m r8152 -v 2.13
sudo dkms build -m r8152 -v 2.13
sudo dkms install -m r8152 -v 2.13

Перезавантажити ПК.

ProxMox додати raw vps.

  1. створити VPS в графічній оболочці ProxMox, задати VM ID наприклад 100
  2. Відкріпити та видалити диск в графічній оболочці VM
  3. В консолі ввести команду qm importdisk 100 /path/to/your/image.raw local, де 100 — ID віртуальної машини, а local назва розділу для зберігання даних VPS.
  4. Диск додасться як «unused» на VM 100.
  5. Натиснути двічі на диск, додати до VM.
  6. Вибрати пріоритет завантаження для нового диску.
  7. Запустити VM.

Добавление домена в белый список антиспама Zimbra

Добавление домена в белый список:

1. su zimbra
2. nano /opt/zimbra/conf/amavisd.conf.in
3. Ищем строку, которая начинается с:
{ # a hash-type lookup table (associative array) и добавляем доверенный домен перед всеми остальными записями: ‘gmail.com’     =>                  -10.0,

4. Сохраняем файл и перезапускаем антиспам командой: zmamavisdctl stop && zmamavisdctl start

Добавление домена в чёрный список:

1. su zimbra
2. nano /opt/zimbra/conf/salocal.cf.in
3. Ищем строку, которая начинается с: # accept email from zimbra support and forumns
4. Добавляем блокируемый домен (например блокируем всю почту из домена .tk)
blacklist_from *.tk
5. Сохраняем файл и перезапускаем Zimbra командой
zmcontrol stop && zmcontrol start

Обновление сервера почты Zimbra до 8.8.15

https://www.zimbra.com/downloads/zimbra-collaboration-open-source/

На странице обновлений зимбра копируем ссылку для своей версии или загружаем обновление.

cd ~
wget https://files.zimbra.com/downloads/8.8.15_GA/zcs-8.8.15_GA_3869.RHEL7_64.20190918004220.tgz

распаковываем архив:

tar -xvf zcs-8.8.15_GA_3869.RHEL7_64.20190918004220.tgz

заходим в директорию и приступаем к установке

cd zcs-8.8.15_GA_3869.RHEL7_64.20190918004220

./install.sh

Проверяем работу сервиса:

su zimbra
zmcontrol status

Как сбросить пароль root в VMware ESXi

Загружаемся с любого LiveCD.


sudo su
mkdir /boot2 /temp
mount /dev/sda5 /boot2
cd /boot2
cp state.tgz /temp
cd /temp
tar -xf state.tgz
tar -xf local.tgz
rm *.tgz
cd etc

редактируем файл shadow (через nano или vi), убераем вс’ что между первого двоеточия оставляя вид root::19424:0:99999:7:::, сохраняем

cd ..
tar -cf local.tgz etc/
tar -cf state.tgz local.tgz
mv state.tgz /boot2
umount /boot2
reboot

авторизируемся с пустым паролем, меняем пароль

Доступ к cisco с определенного адреса

Подключаемся к консоле CISCO:

  1. входим в раздел администрирования: conf t

2. Войдите в режим конфигурации списка доступа под именем ADMIN-MGT и добавьте запись deny any в конец ACL-списка.

cisco(config)# ip access-list standard ADMIN-MGT 
cisco(config-std-nacl)#

3. добавьте доступ к устройству для определенного IP либо подсети

cisco(config-std-nacl)# permit host 192.168.77.77
( Доступ с IP 192.168.77.77 )

cisco(config-std-nacl)# permit 192.168.77.10 0.0.0.10
( Доступ с диапазона IP 192.168.77.10- 192.168.77.20 )

Создание запрещающей записи не требуется, поскольку в конце любого ACL-списка имеется косвенная запись deny any.

Теперь, когда вы создали именованный список ACL, примените его на каналах vty.

cisco(config)# line vty 0 4 
cisco(config-line)# access-class ADMIN-MGT in 
cisco(config-line)# exit

проверяем доступ к устройству с IP вне указаного диапазона, если все верно — сохраняем конфигурацию
copy running-config startup-config

R1(config-std-nacl)# exit

Проброс Електронного ключа (токен) АВТОР Электронный ключ SecureToken-337F на PVE PROXMOX VPS

Создаем виртуальную машину с стандартными параметрами Windows 10.
В разделе Hardware добавляем USB устройство и порт.

Изменяем Microsoft Group Policy для отключения проброса устройства, для корректной работы с токеном средством RDP.

Открываем Local Group Policy

Переходим в раздел Конфигурация компьютера, Административные шаблоны, Компоненты Windows

Службы удаленного рабочего стола -> Узел сеанса удаленного рабочего стола -> Перенаправление устройств и ресурсов.

Включить «Не разрешать перенаправление дисков» (возможно и смарт карт ниже в меню)

Установить расширение ИИТ Пользователь ЦСК-1. Библ. подп. (web-р.)

и EUSignWebInstall.exe http://iit.com.ua/download/productfiles/EUSignWebInstall.exe

Авторизоваться на необходимом сайте.

The used table type doesn’t support FULLTEXT indexes

FULLTEXT доступен только в MyISAM, меняем тип таблицы
MyISAM и после чего выполняем запрос к БД

ALTER TABLE ost__search ENGINE = MyISAM;
ALTER TABLE ost__search
ADD PRIMARY KEY (object_type,object_id);
ALTER TABLE ost__search ADD FULLTEXT KEY search (title,content);

Резервный L2TP-Server Mikroik

Имеется сеть: Основной Mikrotik (l2tp сервер+доступ в интернет) и Mikrotik в роли L3 коммутатора, необходимо сделать резерв l2tp сервера.

  1. Настраиваем резервый Mikrotik под L2TP аналогично основному используя уникальные IP для PPP-Secrets, MTU на несколько значений выше и те же route

2. Со стороны клиента добавляет второе подключение L2TP (Interfaces — Add — L2TP Client)

IP — Route добавляем второй L2TP сервер.
со шлюзом на резервный L2TP сервер и большой
distance c комментом reserv

Для основного канала ставим коммент main

Переходим в Tools — Netwatch и добавляем правило блокировки второго канала в случае доступности основного:
IP — IP для l2tp канала данного офиса с основного Mikrotik

Если канал доступен:

/ip route set [find comment=»vpn-main»] disabled=no

/ip route set [find comment=»vpn-resern»] disabled=yes

Если канал недоступен то:

/ip route set [find comment=»vpn-main»] disabled=yes
/ip route set [find comment=»vpn-reserv»] disabled=no


3. На L3 Mikrotik дублируем route для l2tp подключений с указанием резервного шлюза с distance на 1 больше основного:

4. Добавляем автоматическое переключение шлюзов. Переходим в Tools — Netwatch и добавляем правило:

Где 10.20.20.30 IP адрес который пингуем для определения доступен ни канал (в моем случае это IP который получает клиент в качестве Pref.Source IP от основного Mukrotik)
Интервал 5 секунд, обычно достаточно 1 минуты.

UP: в случае доступности IP отключаем резерв и активируем основной канал:
/ip route set [find comment=»main-l2tp-user1″] disabled=no
/ip route set [find comment=»reserve-l2tp-user1″] disabled=yes

DOWN: в случае отсутствия пинга к IP отключаем основной канал и активируем резервный канал:
/ip route set [find comment=»main-l2tp-user1″] disabled=yes
/ip route set [find comment=»reserve-l2tp-user1″] disabled=no

IT блог