Несколько версий PHP на ISPmanager Pro

В качестве cgi установим php 5.5.9

Качаем php во временную директорию и распаковываем

cd /tmp
wget http://museum.php.net/php5/php-5.5.9.tar.gz
tar xzvf php-5.5.9.tar.gz
cd php-5.5.9

Собираем:

./configure --prefix=/opt/php55 \
--with-config-file-path=/opt/php55/etc \
--with-config-file-scan-dir=/opt/php55/etc/php.d \
--with-libdir=lib64 \
--with-mysql \
--with-pdo-mysql \
--with-mysqli \
--with-curl \
--with-gd \
--with-pic \
--with-bz2 \
--with-iconv \
--with-zlib \
--with-jpeg-dir \
--with-png-dir \
--enable-cli \
--enable-pdo \
--enable-exif \
--enable-ftp \
--enable-magic-quotes \
--enable-fastcgi \
--enable-discard-path \
--enable-force-cgi-redirect

Возможны ошибки
no acceptable cc found in $PATH — нет компилятора GCC
Решение:
yum install gcc

и т.д.
yum install libxml2-devel bzip2-devel curl-devel libjpeg-devel libpng-devel libX11-devel gd-devel libc-client-devel libmcrypt-devel mysql-devel

Компилим и устанавливаем.
make
make install

Для операционной системы CentOS, панель управления хостингом ISPmanager в обертку php прописывает путь к php-cgi как /usr/bin/php-cgi, который является бинарником php 5.3. Т.к. мы используем данную версию интерпретатора в модуле апача, то данный бинарник нам не нужен. Удаляем и вместо него делаем ссылку на наш новый php-cgi:
rm /usr/bin/php-cgi
ln -s /opt/php55/bin/php-cgi /usr/bin/php-cgi

Проконтролировать, какие модули были установлены можно командой

/usr/bin/php-cgi -m
Теперь выставляем для пользователя хостинга право выполнять «php как cgi», и в данном режиме будет использоваться php версии 5.5.9, если же для домена в панели управления хостинга установить режим «php как модуль Апач», то будет задействована php 5.3.

Добавить комментарий